Автонастройка

Шли дни, поступали все новые вопросы от пользователей PHPSECURE, а я все отчетливей понимал, что в текущих реалиях, многие создатели и владельцы сайтов, с трудом оперируют даже в таких простых интерфейсах, как админка WordPress. Что уж говорить об узкоспециализированном продукте, предназначенном для предотвращения взлома и пресечения хакерских атак…
Иными словами, я все отчетливей понимал необходимость создания чего-то, вроде упрощенного интерфейса и/или мастера настройки, чтобы пользоваться PHPSECURE с комфортом могли и неподготовленные пользователи.

Вначале, я наполнял сайт phpsecure всё новыми статьями, стремительно нарастив раздел помощи, но разве ж объяснишь человеку, как предотвратить запрос к MySQL-таблице wp_users, если человек вообще не знает, что на свете бывают таблицы БД MySQL.

Много мыслей было по поводу упрощенных интерфейсов. Много «совещаний» со знакомыми и сводилось все к тому, что упрощенный интерфейс и мастера (визарды) настроек, где можно по нажимать на кнопочки, ответив на вопросы типа (какая у Вас CMS), определенно нужны.

Но я же не ищу легких путей! Я же не могу делать как заведено, это ж блин не интересно! Вон, например, заведено вообще не защищать сайты от взлома, а просто восстанавливать их из бэкапа снова и снова, пока хостеру не надоест и он не пошлет подальше… Что ж теперь — быть как все?
А если серьезно — то просто понимал, что для того, чтобы правильно ответить на вопросы визарда, тоже нужно обладать хотябы какими-либо знаниями.

В общем я пошел дальше всяческих визардов и упрощенных интерфейсов и научил PHPSECURE настраиваться полностью в автоматическом режиме.

С этого момента стало возможным просто установить PHPSECURE три раза нажав на кнопку и больше вообще ничего не делать — все остальное PHPSECURE научился делать самостоятельно.

Конечно же, когда я говорю о полной автоматизации настройки, умалчивается тот факт, что никакой искусственный интеллект не заменит тонкой настройки, выполненной хорошо подготовленным специалистом.
Но разве нужна авто-настройка специалистам? :) А вот для того, чтобы защитить сайт неподготовленного пользователя лучше, чем это сделал бы сам пользователь, «мозгов» у PHPSECURE стало вполне достаточно.